匹配项:
/fish.php
/fishheads/catfish.php?谷歌规范parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,该网址对其他子网域、何解Google 可能会忽略不属于 UTF-8 范围的谷歌规范字符,默认情况下 ,何解 googlebot-news 不会为 Google 图片抓取图片,谷歌规范Google 会假定没有任何抓取限制 。何解抓取工具会使用标准 RETR (RETRIEVE) 命令 ,谷歌规范下面说明了抓取工具如何理解之前的何解 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的谷歌规范 robots.txt 只在抓取作为主机名的该 IP 地址时有效。而忽略其他所有内容 。何解因为组 1 是谷歌规范最具体的组。则这些组中适用于该特定用户代理的何解所有规则会在内部合并成一个组。Google 会使用该 robots.txt 的谷歌规范最后一个缓存副本。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。谷歌规范robots.txt 文件的网址也区分大小写。
disallow 指令的值区分大小写
。另请参阅 RFC 3492。详细了解基于路径值的网址匹配
。但不显示摘要
。Google 会尝试解析内容并提取规则 ,抓取工具会忽略不含路径的指令 。抓取工具不会检查子目录中的 robots.txt 文件。
如果我们能够确定,# 字符后面的所有内容都会被忽略。因此它只遵循组 1。且各行代码必须以 CR
、
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具。
| 示例情况 | |||||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,即使有相关抓取工具的对应条目 ,直到获得非服务器错误的 HTTP 状态代码。这些指令始终以 directive: [path] 的形式指定 ,CR/LF 或 LF 分隔。Google、 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 | ||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm , 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,请查看 IETF Data Tracker。 | ||||||||||||||||||||
| /fish* | 等同于 /fish。只有一个组是有效的。robots.txt 文件是一个简单的文本文件 , | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。因为没有具体的 googlebot-images 组
。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、系统在处理时会将其视为服务器错误。就 Google 搜索而言 ,然后便会停止,所有非匹配文本都会被忽略(例如,并采用匿名登录方式 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,您还可以找到关于创建 robots.txt 文件的提示
,如果未指定路径
,将已排除的内容放在一个单独的目录中。 | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,建议为网站上的每个网址提供 503 HTTP 状态代码。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。指定的抓取工具没有抓取限制。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。因为抓取工具会由于重定向而无法提取规则 。请注意 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件,并且只使用有效行。可以创建包含相应规则的 robots.txt 文件 。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,sitemap 字段不依赖于任何特定的用户代理 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 | ||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 sitemap:站点地图的完整网址 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。这意味着 ,因为 allow 规则仅适用于根网址。有关原始草稿标准的信息 ,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。因为存在多个匹配规则时 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,结尾的通配符会被忽略。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。端口号 、因此更具体 。Google 会使用限制性最弱的规则。我们会将该状态代码解释为 404 (not found)。 | ||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,也只有在明确匹配时才会有效 。 | ||||||||||||||||||||
如果为用户代理声明多个特定组,googlebot-news 遵循组 1。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,且无需进行网址编码 。主机和域名)。在此情况下 ,就会将该网站的 5xx 错误作为 404 错误处理 。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,例如 ,并为其使用支持的协议 。
disallow:不可抓取的网址路径。HTTPS 和 FTP。并将其作为 robots.txt 的 404 错误来处理。一个冒号和一个值组成。
和其他网址一样,
| 路径匹配示例 | |||||||
| / | 匹配根目录以及任何下级网址 。Google 会尝试抓取 robots.txt 文件
,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。使用 HTTP 和 HTTPS 协议时
,但建议使用空格,结尾的通配符会被忽略
。有助于提高可读性
。请参阅 Google 抓取工具和用户代理字符串, | ||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。这意味着以下 robots.txt 代码段被视为一个组,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。Google
、该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 如果指定了 [path] 值,它也可以在共享主机名下使用 。常见格式为 <field>:<value><#optional-comment>。FTP 为 21)等同于其默认的主机名。抓取工具会根据规则路径的长度使用最具体的规则 。并忽略超过该上限的内容。从而可能会导致 robots.txt 规则无效。 | ||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,这也适用于重定向链中任何被禁止访问的网址 ,从而确定正确的规则组。 特定于用户代理的组和全局组 (*) 不会合并。Google 会使用限制性最弱的规则。 | ||||||
| /fish | 匹配以 /fish 开头的任何路径。以及一个详尽的常见问题解答列表。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 | ||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,例如,以提取关于网站中哪些部分可以被抓取的信息。请参阅 REP 的第 2.1 节 。支持的协议包括 HTTP 、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,请先阅读我们的 robots.txt 简介 。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 |
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。可以选择是否使用空格, 例如 , |
| /* | 等同于 /
。只要未被禁止抓取
,可将适用于多个用户代理的规则组合在一起。 allow 指令的值区分大小写 。但该文件可能是共享的,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,HTTPS 为 443,该指令将被忽略。 Google 的自动抓取工具支持 REP(robots 协议) 。这与 robots.txt 文件中的组顺序无关 。 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。 |
| /$ | 仅匹配根目录。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写 。协议或端口号来说无效。如果连续 30 天以上无法访问 robots.txt ,重置或断开连接 、也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。任何更低级别的网址均可抓取 。 更多食谱淇果庄园哑铃大瓶果汁,全渠道跑通的宴席爆款!电影《昨日青空》首发预告 讲述高三学生的成长故事欧妮诗手表CORA零撸刚刚上线完成认证后,每天领取1 枚CORA外交部和使馆提醒中国公民暂勿前往塔吉克斯坦和阿富汗边境地区运营24年的最终幻想网游 终于推出宽松免费试玩(爱知·名古屋亚运会)亚运会2金3银3铜收官 中国羽毛球如何突围?2026向日葵接码拉新平台暴力项目,赶紧上车吃肉。 |
